tcp-stream-proxy/package.nix

35 lines
716 B
Nix

{ pkgs ? import <nixpkgs> { } }:
with pkgs;
let
version = "0.0.2";
deps = [ ];
nativeDeps = [ ];
in
pkgs.buildGo119Module {
pname = "tcp-stream-proxy";
inherit version;
src = ./.;
buildInputs = [
stdenv
] ++deps;
nativeBuildInputs = [
musl
] ++nativeDeps;
tags = [ ];
CGO_ENABLED = 0;
ldflags = [
"-s" "-w"
"-linkmode external"
"-extldflags '-static -L${musl}/lib'"
];
allowGoReference = false;
#vendorSha256 = lib.fakeSha256;
vendorSha256 = "sha256-YFKyN+oV9MrjcvfehsGKgvAPvnHlOBGpSQpVdrOvUog=";
meta = {
description = "A little Proxy which forwards TCP streams";
homepage = "https://git.entr0py.de/garionion/tcp-stream-proxy";
};
}